Home > Java, NetBeans, Redmine > RedmineNB V1.1 for NetBeans 7.2.1 released

RedmineNB V1.1 for NetBeans 7.2.1 released

RedmineNB V1.1 has been just released. It includes new features and many bugfixes for the V1.0.x releases. Since RedmineNB has an implementation dependency to the Issue Tracking module, this version is only compatible with the NetBeans IDE 7.2.1 (Build 201210100934).

A Redmine V1.3+ installation is recommended for best compatibility (tested against Redmine V2.1.0). There are some limitations in the functionality since the used Redmine REST API is not yet fully developed. This page gives an overview of the Redmine REST API functionality.

Find Issues panel

What’s New?

RedmineNB V1.1 includes many bug fixes and improvements. The changes includes:

Screenshots

There’s a new Redmine Wiki markup viewer for the issue description. The implementation (still a prototype) is based on Mylyn WikiText to converting the Textile markup to HTML. For HTML rendering the capabilities of the Swing JLabel component is used.

SubTask Issue Detail panel

 

An issue listed as Action Item using the toggle button in the upper right toolbar:

Notes

Links

About these ads
Categories: Java, NetBeans, Redmine
  1. 2012-10-30 at 14:21 | #1

    Is really important to have this API released. It’ll lead to support of multiple Issue Trackers from the community as well as other interesting functionality.

  2. 2012-10-30 at 18:38 | #2

    Great job ! Thanks for all !

  3. Matthias
    2013-02-7 at 21:47 | #3

    Today the netbeans devs released an update for the issue tracker module – it bumps the specification version and in so enforces an update for netbeans 7.2 and 7.2.1 bringing both version to the same specification version. This enables you (and me (Mantis Integration)) to support 7.2 and 7.2.1.

    • 2013-02-7 at 23:01 | #4

      Hi Matthias
      Thank you for your comment. I’ve just released the new V1.1.1.

  4. tku
    2013-02-27 at 20:10 | #5

    Hello, please add support for 7.3. It’s final release now and I would love to use your plugin.

  5. Paulo Costa
    2013-03-10 at 04:02 | #7

    Do you know when it will be possible to have for the version Netbeans 7.3

  6. Ender Wiggin
    2013-05-25 at 00:08 | #9

    Trying to download version specific to 7.2.1 but can’t locate it. Does anyone have a link to have a binary or should I check out and try building it ?

  7. kriboogh
    2013-08-29 at 10:58 | #13

    Wondering if you guys are also looking into compatibility for Netbeans 7.4(beta) or might know a trick to make it install. I tried to install RedmineNB through adding the repository to the plugin center, but I got the dependency for the issue tracking module error.

  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

%d bloggers like this: